So, who wants a nice working forum then?

Manchester United chat
User avatar
FuB
Legend
Posts: 4559
Joined: 3 years ago
Location: Littlewoods Data Entry Department

10 months ago

All...

Thanks for the kind words and appreciation that you've all shown. I haven't done this to get plaudits, though. i'm doing it because the issues we've been having have done my head in as much as the next man but i'm at least in a position where I have the skillset to try and fix it.

That said, when I got the test copy I was working on "fixed" so that I could see quotes again and no fucking PHP error strings in the headers, I was so pleased with myself I made the cardinal error of not actually testing any further and just assuming that it was all working fine. If any of my colleagues over the years had done that, I'd have been merciless with them so i'm feeling a little bit embarrassed to pronounce a "fix" that, even with my post pronouncing it, showed to me that it wasn't (i.e. the blank page or internal server error (500) - depending on how you have your browser set up. most hide errors and try to give a friendly page instead).

Anyway... oops!

I'm now looking at this bit but, in the meantime, just be careful because a refresh on the blank page/500 error will cause the double posts we've been seeing. your post WAS posted, just hit the back button and refresh from there.... as Robbo says.

Will let you know more as and when I see it. I can see the error logs so I know WHAT the problem is. working out how to fix it is the next step of course.
I may be able to fix a forum but I can't fix a fuckwit
User avatar
Robbo
Legend
Posts: 1112
Joined: 5 years ago

10 months ago

FuB wrote:All...

Thanks for the kind words and appreciation that you've all shown. I haven't done this to get plaudits, though. i'm doing it because the issues we've been having have done my head in as much as the next man but i'm at least in a position where I have the skillset to try and fix it.

That said, when I got the test copy I was working on "fixed" so that I could see quotes again and no fucking PHP error strings in the headers, I was so pleased with myself I made the cardinal error of not actually testing any further and just assuming that it was all working fine. If any of my colleagues over the years had done that, I'd have been merciless with them so i'm feeling a little bit embarrassed to pronounce a "fix" that, even with my post pronouncing it, showed to me that it wasn't (i.e. the blank page or internal server error (500) - depending on how you have your browser set up. most hide errors and try to give a friendly page instead).

Anyway... oops!

I'm now looking at this bit but, in the meantime, just be careful because a refresh on the blank page/500 error will cause the double posts we've been seeing. your post WAS posted, just hit the back button and refresh from there.... as Robbo says.

Will let you know more as and when I see it. I can see the error logs so I know WHAT the problem is. working out how to fix it is the next step of course.


Rome wasnt built in a day :-o and the things that you have already fixed make things easier, having run this place for a while after Ed fucked off years ago I know the work involved behind the scenes but do not have the skill set to sort programming errors.

Normally you need to stay Admin as long as you have the time and the interest so that this place runs smoothly always.

All in all as one europhile to another :)) job well done and once youve got the rest sorted all will be well.
-----------------------------------------------------
User avatar
Lazarus
Legend
Posts: 13855
Joined: 5 years ago

10 months ago

swampash wrote:...anyone know how you clear the cash on an Apple Mac?????



My Apple Mac cleared most of my cash when i bought it...... :D
"Respect! Respect! Respect Maan! Respect! Respect!........." [-X
User avatar
FuB
Legend
Posts: 4559
Joined: 3 years ago
Location: Littlewoods Data Entry Department

10 months ago

Robbo wrote:Rome wasnt built in a day :-o and the things that you have already fixed make things easier, having run this place for a while after Ed fucked off years ago I know the work involved behind the scenes but do not have the skill set to sort programming errors.

Normally you need to stay Admin as long as you have the time and the interest so that this place runs smoothly always.

All in all as one europhile to another :)) job well done and once youve got the rest sorted all will be well.


Thanks, Robbo.

It's not really so much a question of fixing programming errors. I can read php pretty well but phpBB is such a complex mishmash of script files that are all dependent on each other that it's like giving me a copy of the source to Microsoft Word and asking me to fix the bugs - sure, I can read c++ but i'm fucked if I would know where to start.

The actual issue is that Ed's hosting company insisted he moved up to php 7.0 which he obligingly did, only to discover that the version of phpBB that we were using isn't compatible. Therefore, he went ahead and tried to upgrade to the latest phpBB (which does support 7.0). This was a bit of a mistake but (a) Ed's really fucking busy with his real life and (b) he's not a techie so didn't really appreciate the intricacies of what he was doing. this was coupled with everyone on the forum whining on at him... and pressure generally leads to mistakes, doesn't it?

So, anyway, the upgrade failed. So he tried it again. It failed again. I think, at this point, he got confused with where he was so everything was left in a fucked up halfway house situation where we've got some crazy mix of versions. I had hoped I could trick the database into thinking it was at a lower version and then upgrading as far as possible with the "non-compatible" version of phpBB. Someone on the web made some patches to "fix" the non-compatible version to actually work with php 7.0 (those preg_replace errors are the problem). I applied that and it all looked good. I think there are some remnants of the newer version still in the script files and these are upsetting the applecart. I'm currently trying to piece together a backup copy Ed made to see if that works better with some upgrades and patches.

Sorry about all the techie shit there... If you're interested, that explains the situation in depth. If you're not, then just ignore this post.

I'll keep you all posted as to my progress but trust that i'm am on it.
I may be able to fix a forum but I can't fix a fuckwit
User avatar
Robbo
Legend
Posts: 1112
Joined: 5 years ago

10 months ago

FuB wrote:
Robbo wrote:Rome wasnt built in a day :-o and the things that you have already fixed make things easier, having run this place for a while after Ed fucked off years ago I know the work involved behind the scenes but do not have the skill set to sort programming errors.

Normally you need to stay Admin as long as you have the time and the interest so that this place runs smoothly always.

All in all as one europhile to another :)) job well done and once youve got the rest sorted all will be well.


Thanks, Robbo.

It's not really so much a question of fixing programming errors. I can read php pretty well but phpBB is such a complex mishmash of script files that are all dependent on each other that it's like giving me a copy of the source to Microsoft Word and asking me to fix the bugs - sure, I can read c++ but i'm fucked if I would know where to start.

The actual issue is that Ed's hosting company insisted he moved up to php 7.0 which he obligingly did, only to discover that the version of phpBB that we were using isn't compatible. Therefore, he went ahead and tried to upgrade to the latest phpBB (which does support 7.0). This was a bit of a mistake but (a) Ed's really fucking busy with his real life and (b) he's not a techie so didn't really appreciate the intricacies of what he was doing. this was coupled with everyone on the forum whining on at him... and pressure generally leads to mistakes, doesn't it?

So, anyway, the upgrade failed. So he tried it again. It failed again. I think, at this point, he got confused with where he was so everything was left in a fucked up halfway house situation where we've got some crazy mix of versions. I had hoped I could trick the database into thinking it was at a lower version and then upgrading as far as possible with the "non-compatible" version of phpBB. Someone on the web made some patches to "fix" the non-compatible version to actually work with php 7.0 (those preg_replace errors are the problem). I applied that and it all looked good. I think there are some remnants of the newer version still in the script files and these are upsetting the applecart. I'm currently trying to piece together a backup copy Ed made to see if that works better with some upgrades and patches.

Sorry about all the techie shit there... If you're interested, that explains the situation in depth. If you're not, then just ignore this post.

I'll keep you all posted as to my progress but trust that i'm am on it.


No doubt that is the cause this mishmash, is it possible to do a fresh install and add all the shitback from a Database backup? havent fucked about with forum software and Databases for a long time and have probably forgotten what I did know =))

No problems with the techie stuff some I know and some I dont but its good finally to have someone who can fix this clusterfuck :ymhug:

Still reckon that as you have the power you should tidy the forum a bit with sub forums instead of these single forums.
-----------------------------------------------------
User avatar
FuB
Legend
Posts: 4559
Joined: 3 years ago
Location: Littlewoods Data Entry Department

10 months ago

Robbo wrote:No doubt that is the cause this mishmash, is it possible to do a fresh install and add all the shitback from a Database backup? havent fucked about with forum software and Databases for a long time and have probably forgotten what I did know =))

No problems with the techie stuff some I know and some I dont but its good finally to have someone who can fix this clusterfuck :ymhug:

Still reckon that as you have the power you should tidy the forum a bit with sub forums instead of these single forums.


fresh install... yeah, that's literally what I have just done in a test folder and, guess what... doesn't work. absolute motherfucker

I went through the phpbb 3.2 install scripts and I couldn't see that it did a whole lot with the db except stamp it with the new version number... so what we're running with now is a database that I manually edited to make it think it was a lower version. this is part of the problem. the db got upgraded but the site went tits up so Ed tried to roll things back.

so, I've got a copy of the db and an absolutely fresh install of phpbb 3.1.12 and that's being a cunt too. I have to conclude that there's more changes to the db than I thought so I'm going to have to start getting annoyed with MySQL's finicky syntax.

one way or another, i'll get this fixed if it kills me. i'm fucked if i'm going to drop the ball now.

Re: being the admin... Right now, all I care is to fix this fucker. I'm open to be the techie who looks after things on a low level and helps bri and alf out. I've let Ed know that by email and, ultimately, that sort of decision is for him and not us. we'll see.
I may be able to fix a forum but I can't fix a fuckwit
User avatar
FuB
Legend
Posts: 4559
Joined: 3 years ago
Location: Littlewoods Data Entry Department

10 months ago

aha... I have found the db change the upgrade made and backed it out... I think
I may be able to fix a forum but I can't fix a fuckwit
User avatar
FuB
Legend
Posts: 4559
Joined: 3 years ago
Location: Littlewoods Data Entry Department

10 months ago

FuB wrote:aha... I have found the db change the upgrade made and backed it out... I think

yes, I fucking have... we're all good on posting
I may be able to fix a forum but I can't fix a fuckwit
User avatar
FuB
Legend
Posts: 4559
Joined: 3 years ago
Location: Littlewoods Data Entry Department

10 months ago

OK. I think I can officially declare the forum "fixed".

It's been a bit of a fight to undo the changes that the cocked up install made so it's possible there are some other issues.

What's DEFINITELY fixed is:

1. The annoying php errors that were output at the top of the page for the last few months
2. quoting and inline html like italics, etc.
3. The blank screen or "500 error" (internal server error) when posting
4. The notifications system. If you had email notifications for PMs and threads set up, they should be working again. They are for me.

Please post here or PM me if you find anything that seems to still be broken and i'll see what I can do to fix things further.

Cheers all.
I may be able to fix a forum but I can't fix a fuckwit
User avatar
Robbo
Legend
Posts: 1112
Joined: 5 years ago

10 months ago

Test .......
-----------------------------------------------------
Post Reply